FOXTEAM UAV CLAN

a Virtual Robotix Network Team

Virtual Robotix IDE Pro is the new IDE for Multipilot32F1 (V1 and V3) and Multipilot32F4

The IDE is based on Eclipse (Indigo version) and uses CodeSourcery GNU toochain for the compilation of source code.

For programming the board it is possible to use DFU utility with USB cable for Multipilot32F1 or DfuSe utility with USB cable for Multipilot32F4.
Both boards can also be used ST-LINK/V2 (USB JTAG) with ST32 ST-LINK Utility

It is also possible to debug directly on the board with ST-LINK/V2 (withST-LINK_gdbserver) or with Olimex JTAG (with OpenOCD)

27 July 2012 
 

Dear Friends, the new name of VR IDE Pro is VR Universal IDE

This is the new revision of VRIDE PRO. It's universal because with only one ide you can build the best opensource software platform for you Autopilot. 
The hardware supported are :
  • VBrain (MP32F4 V4)
  • MP32F4 V3
  • MP32F1 V3
  • MP32F1 V1
  • PX4 work in progress.
  • Autoquad work in progress.
Firmware supported : 
  • Arducopter32
  • Autoquad PX4
  • NuttX OS and Application.

You can dowload it here : 

http://code.google.com/p/multipilot32/downloads/detail?name=vr-univ...

This is the forum support page.

Video Tutorial 
 
 
Below is the link to the first version of the manual

 

Views: 2773

Reply to This

Replies to This Discussion

Great work!!

Virtual Robotix IDE pro change its name and became Virtual Robotix Universal Ide check the repository and download it .

On Win7-64, I downloaded the rar files. I don't know if it is me, my PC setup or Win7, but I was not able to run Eclipse:

-On some files, 7-ZIP reported CRC errors for Eclipse java files.

-Lot of files are duplicated on various rar. I always allowed 7-ZIP to replace the existing file with the one comming from the rar.

-Lunching Eclipse.exe, it stopped with errors.

I'm running Win7 64 bit and can start Eclipse without any errors

But i found that if i download the rar files to a folder, and try tu unrar them to a new subfolder, I get some errors about to long file/folder names.

If I unrar the files to the root on my computer I get no errors during the unrar job.

Could be a error in *.part file or yes could be a problem of name too long is better decompress in the root directory

Best

Roberto

In c:\Lavoro\

Then you get c:\Lavoro\vr-universal-ide\....

If you do that, you do not have to change the "workspaces" folder whrn you start eclipse..

Hope that is correct - Roberto ?

Pfffff, I "unrared" everything at c:\

Still corrupted files: one .jar, some .pdf, cc1.exe, arm-none-eabi-ld.exe and a .chm in the stm lib.

When I launch Eclipse, I got an error with the followin log file:

tons of lines ending with  xxxxx.jar was not resolved.

and

!ENTRY org.eclipse.osgi 4 0 2012-07-31 13:09:07.412
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.cdt.codan.core.application, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application,.......

I used WinRAR from http://www.rarlab.com/download.htm (free download)

Do you get the same result if you try WinRAR ?

 

Best

Oyvind

I forgot to say I am now on another PC, running XP.

Winrar working. Stay tunned....

Winrar is unraring directly the following files. With 7-zip and IZarc, I had to unrar each file manualy.

Hi Angelo,

ok if you have other problem on file i try to produce CRC ID MDA so you can understand if you have some file with problem or not. 

Best

Roberto

And.......Tadaaaaaaaa, Eclipse running now.

So, note that using 7-zip or IZarc to individualy unrar all the files will not work.

As suggested by Oyvind, using Winrar on file  .....part1.rar continues automaticaly with the seven other files, and doesn't give you errors.

Thanks for the help.

Hi Angelo, great to hear that WinRar solved the problem

Best

Oyvind

RSS

Events

© 2019   Created by Roberto Navoni.   Powered by

Badges  |  Report an Issue  |  Terms of Service